aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/cgit-config.install1
-rw-r--r--debian/control9
-rw-r--r--files/etc/cgitrc112
3 files changed, 122 insertions, 0 deletions
diff --git a/debian/cgit-config.install b/debian/cgit-config.install
new file mode 100644
index 0000000..ffe8a82
--- /dev/null
+++ b/debian/cgit-config.install
@@ -0,0 +1 @@
+files/etc/cgitrc /etc
diff --git a/debian/control b/debian/control
index c577b18..a3da6c5 100644
--- a/debian/control
+++ b/debian/control
@@ -41,3 +41,12 @@ Provides: ${diverted-files}
Conflicts: ${diverted-files}
Description: Shione wireguard configuration.
Wireguard configuration for shione.net
+
+Package: cgit-config
+Architecture: all
+Multi-Arch: foreign
+Depends: ${misc:Depends}, nginx-config, cgit, fcgiwrap, python3-pygments python3-docutils python3-markdown
+Provides: ${diverted-files}
+Conflicts: ${diverted-files}
+Description: Shione cgit configuration.
+ Cgit configuration for shione.net
diff --git a/files/etc/cgitrc b/files/etc/cgitrc
new file mode 100644
index 0000000..e166b1c
--- /dev/null
+++ b/files/etc/cgitrc
@@ -0,0 +1,112 @@
+#
+# cgit config
+# see cgitrc(5) for details
+
+# Specify the css url
+css=/cgit.css
+
+# Specify the logo url
+logo=/cgit.png
+
+# Add a cgit favicon
+favicon=/favicon.ico
+
+## Set the title and heading of the repository index page
+root-title=shione.net git repositories
+
+## Set a subheading for the repository index page
+root-desc=renken's unfinished projects
+
+## Specify some default clone urls using macro expansion
+# clone-url=https://git.shione.net/$CGIT_REPO_URL ssh://git@example.com/$CGIT_REPO_URL.git
+clone-url=https://git.shione.net/$CGIT_REPO_URL
+
+# root for all cgit links
+virtual-root=/
+
+## Enable caching of up to 1000 output entries
+cache-size=1000
+
+## Show owner on index page
+enable-index-owner=1
+
+## Allow http transport git clone
+enable-http-clone=1
+
+## Show extra links for each repository on the index page
+enable-index-links=1
+
+## Enable blame page and create links to it from tree page
+enable-blame=1
+
+## Enable ASCII art commit history graph on the log pages
+enable-commit-graph=1
+
+## Show number of added/removed lines per commit on the log pages
+enable-log-linecount=1
+
+## Sort branches by date
+branch-sort=age
+
+## Enable statistics per week, month and quarter
+max-stats=quarter
+
+## Include some more info about example.com on the index page
+## root-readme=/var/www/htdocs/about.html
+
+## Allow download of tar.gz, tar.bz2 and zip-files
+snapshots=tar.gz zip
+
+###
+### List of common mimetypes
+###
+
+mimetype.gif=image/gif
+mimetype.html=text/html
+mimetype.jpg=image/jpeg
+mimetype.jpeg=image/jpeg
+mimetype.pdf=application/pdf
+mimetype.png=image/png
+mimetype.svg=image/svg+xml
+
+# Format markdown, restructuredtext, manpages, text files, and html files
+# through the right converters
+about-filter=/usr/lib/cgit/filters/about-formatting.sh
+
+# Highlight source code with python pygments-based highlighter
+source-filter=/usr/lib/cgit/filters/syntax-highlighting.py
+
+###
+### Search for these files in the root of the default branch of repositories
+### for coming up with the about page:
+###
+readme=:README.md
+readme=:readme.md readme=:README.mkd
+readme=:readme.mkd
+readme=:README.rst
+readme=:readme.rst
+readme=:README.html
+readme=:readme.html
+readme=:README.htm
+readme=:readme.htm
+readme=:README.txt
+readme=:readme.txt
+readme=:README
+readme=:readme
+readme=:INSTALL.md
+readme=:install.md
+readme=:INSTALL.mkd
+readme=:install.mkd
+readme=:INSTALL.rst
+readme=:install.rst
+readme=:INSTALL.html
+readme=:install.html
+readme=:INSTALL.htm
+readme=:install.htm
+readme=:INSTALL.txt
+readme=:install.txt
+readme=:INSTALL
+readme=:install
+
+# Root directory
+scan-path=/var/git/